Botman PHP 7.2.4 opcache

17.09.2018 05:51:58 Просмотров 22 Источник

Я пытаюсь заставить простой разговор работать, а ответ не получается, мне нужно знать, как использовать opcache с botman и php 7.2.4 - WAMP

Я изменил файл php.ini, добавив параметр zend_extension, следуя документации, которую я использую:

use BotMan\BotMan\Cache\DoctrineCache;

$botman = BotManFactory::create($config, new DoctrineCache($doctrineCacheDriver));

Это дает и неопределенную переменную: doctrineCacheDriver error

Функция использует переменную $driver, есть ли дополнительные настройки, которые необходимо настроить.

Любая помощь в настройке кэша, php 7 на wamp, будет очень признательна.

У вопроса есть решение - Посмотреть?

Ответы - Botman PHP 7.2.4 opcache / Botman PHP 7.2.4 opcache

Morena

02.11.2020 02:42:45

Если вы все еще ищете ответ на этот вопрос или кого-то в будущем, выполните следующие действия.

  1. Установите APCu на Windows (WAMPP/XAMPP), используя это руководство.
  2. Запустить Composer требует учение/кэш из командной строки внутри каталога проекта/ приложения

Затем создайте экземпляр класса кэша/драйвера

$doctrineCacheDriver = new \Doctrine\Common\Cache\ApcuCache();

Вот тогда вы можете передать его в BotmanFactory в качестве параметра as, как показано ниже

$botman = BotManFactory::create($config, new DoctrineCache($doctrineCacheDriver));

Вы получили эту ошибку, потому что

$doctrineCacheDriver

не был определен

Помочь в развитии проекта:
Закрыть X