Не удалось найти пакет laravel/laravel с версией 6 в версии, устанавливаемой с помощью вашего PHP версии 5.6.30


Не удалось найти пакет laravel/laravel с версией 6 в версии, устанавливаемой с помощью вашего PHP версии 5.6.30

30.09.2020 08:43:40 Просмотров 7 Источник

Я использую mac os и устанавливаю MAMP 5.7. когда я запускаю PHP -v на терминале, он говорит, что версия PHP-7.2 но когда я пытаюсь создать проект Laravel, я получаю эту ошибку. Я не знаю, почему композитор признает, что версия PHP в 5.6

this is the error

У вопроса есть решение - Посмотреть?

Ответы - Не удалось найти пакет laravel/laravel с версией 6 в версии, устанавливаемой с помощью вашего PHP версии 5.6.30 / Could not find package laravel/laravel with version 6 in a version installable using your PHP version 5.6.30

Является ответом!
Ali Mashl

30.09.2020 09:05:41

Пожалуйста проверьте следующее Это может решить проблему

  1. проверьте псевдоним, данный композитору, чтобы указать на соответствующую версию
  2. попробуйте удалить или обновить ваш Mammp или verserver и удалить данные кэша.
  3. если вы измените версию php в командной строке. проверьте это после перезагрузки вашего компьютера
Помочь в развитии проекта:
Закрыть X