В Разрешении Отказано! при установке расширения в opencart 2.3.0.2

В Разрешении Отказано! при установке расширения в opencart 2.3.0.2

30.11.2016 08:25:59 Просмотров 25 Источник

У меня есть установить расширение "рассылка" и "простой блог" на opencart

2.3.0.2 добавить разрешение в пользователей/европейский уровень, уровень затем также. когда я попытаюсь включить статус, он будет отображать "разрешение отклонено!"сообщение и

не позволяет мне отобразить этот модуль. Но тот же модуль работает нормально один предыдущие версии 2.2.X и один получает ту же проблему и получил решение?

если это связано с проблемой совместимости, где я могу изменить разрешение в коде модуля.

разве кто-нибудь знает.

У вопроса есть решение - Посмотреть?

https://stackoverflow.com/questions/40880919/permission-denied-when-install-extension-in-opencart-2-3-0-2#comment68980849_40880919
Я голосую за то, чтобы закрыть этот вопрос как не относящийся к теме, потому что речь идет о поддержке веб-приложения, а не о программировании. Вероятно, об этом следует спросить через собственные каналы поддержки Opencart.
https://stackoverflow.com/questions/40880919/permission-denied-when-install-extension-in-opencart-2-3-0-2#comment68982085_40880919
В opencart 2302 каталог модулей изменился, ищите свои файлы модулей, есть ли в правильном каталоге? Можете ли вы предоставить ссылку для загрузки модулей?
https://stackoverflow.com/questions/40880919/permission-denied-when-install-extension-in-opencart-2-3-0-2#comment69031919_40880919
Этот модуль не совместим с 2.3.0.2
https://stackoverflow.com/questions/40880919/permission-denied-when-install-extension-in-opencart-2-3-0-2#comment69144201_40880919
я совместим для 2.0, но он все еще работает на 2.2, так есть ли какие-либо изменения на модуле, где мы можем установить разрешение?
https://stackoverflow.com/questions/40880919/permission-denied-when-install-extension-in-opencart-2-3-0-2#comment77491435_40880919
@SamirKarmacharya есть ли какое-либо решение, которое вы нашли для этого решения? Я действительно беспомощен здесь.
https://stackoverflow.com/questions/40880919/permission-denied-when-install-extension-in-opencart-2-3-0-2#comment78213950_40880919
я должен изменить все расположение файлов и модифицировать файлы в соответствии с 2.3.X и это прекрасно работает

Ответы - В Разрешении Отказано! при установке расширения в opencart 2.3.0.2 / Permission Denied! when install extension in opencart 2.3.0.2

serkanbalta

30.11.2016 09:11:25

Перейдите в Настройки > Пользователи> > группы пользователей, а затем выберите, к какой группе пользователей принадлежит ваш администратор. Вы увидите "разрешения доступа"и" изменить разрешения". Нажмите на ссылку "проверить все" для обеих групп разрешений, чем сохранить. Вы хорошо идете :)

https://stackoverflow.com/questions/40880919/permission-denied-when-install-extension-in-opencart-2-3-0-2/40881484#comment94559801_40881484
Работать на меня. Я добавил Все разрешения администратору. Спасибо
BartH

04.12.2016 11:31:44

Скорее всего, установка модуля не позволяет установить права группы пользователей. Вы можете сделать это вручную.

  • Войти к вам PHPMyAdmin
  • Перейти к таблице oc_user_group
  • Изменить идентификатор группы пользователей 1
  • Добавьте и экземпляр вашего расширения по следующему примеру расширение / модуль / имя_модуля
  • Сохранить
  • Перейти к модулю в разделе администратор
https://stackoverflow.com/questions/40880919/permission-denied-when-install-extension-in-opencart-2-3-0-2/40963310#comment69144158_40963310
В группе базы данных id =1 и name =Administrator в поле разрешения также отображается имя модуля. но это не сработало.
https://stackoverflow.com/questions/40880919/permission-denied-when-install-extension-in-opencart-2-3-0-2/40963310#comment69187009_40963310
Возможно, эти модули требуют доступа на запись в каталог таблицы базы данных. Есть ли ошибка в журнале?
Treasure

30.04.2018 01:10:54

Забудьте о регулировочных таблицах Вам не нужно ничего менять в вашей базе данных, чтобы устранить эту проблему

Вот пример из более старой версии контроллера: Код: выбрать все

        $this->redirect($this->url->link('extension/module', 'token=' . $this->session->data['token'], 'SSL'));

Теперь его следует записать так:: Код: выбрать все

        $this->redirect($this->url->link('extension/extension', 'token=' . $this->session->data['token'], 'SSL'));

Поэтому, если у вас есть старый модуль, проверьте свой контроллер, т. е. admin/controller/module/yourmodule.РНР затем найдите 'расширение / модуль' заменить 'расширение/extension'

Rahul

30.07.2019 07:17:19

$this->user>->hasPermission( 'modify', extension/extension);
Закрыть X