Странный ответ команды sudo apt-get dist-upgrade

Странный ответ команды sudo apt-get dist-upgrade

28.12.2016 03:46:45 Просмотров 28 Источник

Комадна sudo apt-get dist-upgrade отдает ответ:

Reading package lists... Done

Building dependency tree

Reading state information... Done

You might want to run 'apt-get -f install' to correct these.

The following packages have unmet dependencies:

libc6-dev : Depends: libc6 (= 2.19-18+deb8u6) but 2.19-18 is installed

libc6-i386 : Depends: libc6 (= 2.19-18+deb8u6) but 2.19-18 is installed

libc6-x32 : Depends: libc6 (= 2.19-18+deb8u6) but 2.19-18 is installed

E: Unmet dependencies. Try using -f.

Скажите, что это значит?

У вопроса есть решение - Посмотреть?

https://ru.stackoverflow.com/questions/608862/%d0%a1%d1%82%d1%80%d0%b0%d0%bd%d0%bd%d1%8b%d0%b9-%d0%be%d1%82%d0%b2%d0%b5%d1%82-%d0%ba%d0%be%d0%bc%d0%b0%d0%bd%d0%b4%d1%8b-sudo-apt-get-dist-upgrade#comment832949_608862
в чём заключается вопрос то? )
https://ru.stackoverflow.com/questions/608862/%d0%a1%d1%82%d1%80%d0%b0%d0%bd%d0%bd%d1%8b%d0%b9-%d0%be%d1%82%d0%b2%d0%b5%d1%82-%d0%ba%d0%be%d0%bc%d0%b0%d0%bd%d0%b4%d1%8b-sudo-apt-get-dist-upgrade#comment832960_608862
В том, что не должно так работать и нужно как-то поправить )
https://ru.stackoverflow.com/questions/608862/%d0%a1%d1%82%d1%80%d0%b0%d0%bd%d0%bd%d1%8b%d0%b9-%d0%be%d1%82%d0%b2%d0%b5%d1%82-%d0%ba%d0%be%d0%bc%d0%b0%d0%bd%d0%b4%d1%8b-sudo-apt-get-dist-upgrade#comment832977_608862
сделайте новую виртуальную машину и попробуйте на ней
https://ru.stackoverflow.com/questions/608862/%d0%a1%d1%82%d1%80%d0%b0%d0%bd%d0%bd%d1%8b%d0%b9-%d0%be%d1%82%d0%b2%d0%b5%d1%82-%d0%ba%d0%be%d0%bc%d0%b0%d0%bd%d0%b4%d1%8b-sudo-apt-get-dist-upgrade#comment833431_608862
Где ты такие кривые виртуалки берёшь?

Ответы - Странный ответ команды sudo apt-get dist-upgrade / Странный ответ команды sudo apt-get dist-upgrade

aleksandr barakin

29.12.2016 09:45:44

You might want to run 'apt-get -f install' to correct these.
...
E: Unmet dependencies. Try using -f.

у установленных на данный момент пакетов (перечислены в тексте сообщения) есть неудовлетворённые на данный момент зависимости.

чтобы исправить эту «нуудовлетворённость», надо выполнить предложенную в сообщении команду:

$ sudo apt-get -f install
Является ответом!
Sergey

30.12.2016 05:46:29

Совет выполнить команду

sudo apt-get -f install

скорее всего, ничего не даст. Опция -f приказывает сделать это, несмотря на все несоответствия. Смотрите, что пишет apt:

libc6-dev : Depends: libc6 (= 2.19-18+deb8u6) but 2.19-18 is installed

Это означает, что apt пытается уствановить пакет libc6-dev и этот пакет зависит пакета libc6 (что очевидно), а версия этого пакета должна быть 2.19-18+deb8u6. А в Вашей системе установлен этот пакет с версией 2.19-18. Т.е. версии ОТЛИЧАЮТСЯ. И apt не может найти в текущих репозитариях версию 2.19-18+deb8u6.

Рискну предположить, что в процессе эксплуатации системы Вы как-то меняли репозитарии. Или подключали "левые". В результате этого сложилась такая ситуация, когда часть пакетов в системе взяты из одного репозитария, а часть - из другого. И они различаются версиями.

Разрулить такую ситуацию достаточно сложно... Нужно удалять все пакеты, для которых нет нужных зависимостей, а затем инсталлировать их заново. Зачастую бывает проще переустановить ОС. :-(

https://ru.stackoverflow.com/questions/608862/%d0%a1%d1%82%d1%80%d0%b0%d0%bd%d0%bd%d1%8b%d0%b9-%d0%be%d1%82%d0%b2%d0%b5%d1%82-%d0%ba%d0%be%d0%bc%d0%b0%d0%bd%d0%b4%d1%8b-sudo-apt-get-dist-upgrade/609417#comment834669_609417
Спасибо за ответ, Сергей!
Закрыть X