Вопросы и ответы - npm

Вопросы и ответы - npm



Есть ответ!
У меня большая Vue.js приложение, с помощью Vuetify В1.5 я хотел бы, чтобы переход в приложение до версии 2.0. Но, это создало бы множество критических изменений, и у нас нет времени, чтобы переписать все компоненты для поддержки Vuetify 2.0. Но, с помощью Vuetify 2.0 для создания функции с этого момента, у нас было бы меньше работы, чтобы сделать, когда мы вернемся и обновления на 1.5 штуки. Возм...
Есть ответ!
Я последовал за руководством, чтобы узнать о том, как публиковать пакеты в NpmJS. Но когда я обновил README.MD и попытался обновить пакет на NpmJS, я получил следующую ошибку: npm version patch npm ERR! Git working directory not clean. npm ERR! A .gitignore npm ERR! AM README.md npm ERR! A babel.config.js npm ERR! AM package-lock.json npm ERR! AM package.json npm ERR! AD public/favicon.ico npm E...
Есть ответ!
Я создал небольшое приложение vue с помощью vue-cli. Я использую npm run build для создания производственной версии пользовательского интерфейса, которая заканчивается кучей CSS, js и HTML-файлом страницы, содержащим все эти файлы js и CSS. Однако для целей приложения HTML-код должен быть перемещен в другой каталог, где к нему обращается промежуточное программное обеспечение. Вот почему URL-адрес ...
Есть ответ!
Привет, я разрабатываю проект и по некоторым причинам не могу использовать какие-либо модули webpack и node. Я также не могу использовать никакой cdn. Проект vue будет содержать только клиентские компоненты. Мне не нужно рассматривать бэкэнд-часть, маршрутизацию и т. д. Размер проекта имеет значение, поэтому мне не разрешается использовать узловые модули. Как я могу создать только клиентский проек...
Есть ответ!
Я могу создать пакет npm, экспортировав одну директиву vue в src/index.js файл. Но как я могу создать пакет, который позволяет использовать несколько директив vue? Я не могу экспортировать две директивы vue в одну и ту же index.js файл. export default Vue.directive('directive1', { inserted: function (el, binding, vnode) { el.addEventListener('mouseup', (e) => mouseup(e, el, _data)) el...
Есть ответ!
Я создал проект Laravel 5.8 и хочу установить npm. Поэтому я набрал npm install, но получил это сообщение: npm WARN deprecated popper.js@1.16.1: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1 npm WARN deprecated urix@0.1.0: Please see https://github.com/lydell/urix#deprecated npm WARN deprecated chokidar@2.1.8: Chokidar 2 will break on node v14+. Upgra...
Есть ответ!
Я создавал новый проект laravel и во время установки npm произошла эта ошибка Команда, которую я запустил, была npm install - Laravel Framework 8.6.0 Версия Для Узла:- 8.10.0 Ошибка:- npm WARN deprecated popper.js@1.16.1: You can find the new Popper v2 at @popperjs/core, this package is dedicated to the legacy v1 loadDevDep:vue-template-c - |################---------------------------------| WARN...
Есть ответ!
Я пытаюсь установить npm в папку laravel homestead, но получаю эти сообщения об ошибках. сообщения об ошибках в терминале
Есть ответ!
Проблема В данный момент я следую рекомендациям jqwidgets по ссылке, показанной ниже,чтобы создать выпадающий список. Единственная проблема с их настройкой заключается в том, что они используют функцию импорта, которую я не могу использовать из-за ограничений со стороны моего techlead. Мой вопрос Есть ли способ заставить плагин работать в моем html-файле и без функции импорта, например, через CDN?...
Есть ответ!
когда я запускаю "npm run watch", это то, что я получаю. Это свежий проект laravel 8. Я только что использовал пакет Auth. Вот вам и компонент:- <template> <div class="col-md-8 mt-4"> <div class="card card-default"> <div class="card-header"> Task Form </div> <div cl...
Есть ответ!
Я создал проект с vue CLI vue create my-project и получил эту ошибку: npm ERR! code EUNSUPPORTEDPROTOCOL npm ERR! Unsupported URL Type "npm:": npm:vue-loader@^16.0.0-beta.3 npm ERR! A complete log of this run can be found in: npm ERR! /home/n/.npm/_logs/2020-09-10T05_10_36_489Z-debug.log Версия Npm: 6.14.8, версия узла: 10.15.2. Я погуглил эту ошибку, но их ответы не работают для м...
Есть ответ!
Я изучаю Vue js, и когда я пытаюсь запустить npm run watch, он говорит, что Build successfully, но затем по некоторым причинам терминальный процесс останавливается, и я получаю ошибку типа: Ошибка из chokidar (в/var/www в/HTML-код/rankUp/папки node_modules/Аксиос): ошибка: ENOSPC: систему лимита на количество наблюдателей достигло файл, смотреть в/var/www в/HTML-код/rankUp/папки node_modules/Акси...
Есть ответ!
@ Дев D:\xampp\htdocs\sports НПМ области @ разработка D:\xampp\htdocs\sports cross-env NODE_ENV=разработка node_modules/webpack/bin/webpack.js --прогресс --скрыть модули --config=node_modules/laravel-mix/setup/webpack.config.js "cross-env" не распознается как внутренняя или внешняя команда, действующая программа или пакетный файл. npm ERR! код ELIFECYCLE npm ERR! Ошибка 1 НПМ ошибаться! @ развит...
Есть ответ!
Я получаю: Failed to load resource: net::ERR_CONTENT_LENGTH_MISMATCH chunk-vendors.js:1 в консоли Google Chrome и пустой странице при попытке загрузить страницу разработки Vue запускается через: user@ubuntu:~# npm run serve DONE Compiled successfully in 11909ms App running at: - Local: http://(my_public_ip):5008/ - Network: http://(my_public_ip):5008/ Note that the development bu...
Есть ответ!
Я хотел бы установить самую последнюю версию Ember на мой Mac с MacOS Catalina. Я действительно думал, что сделал это несколько недель назад (этой машине всего три месяца), но ember -v говорит, что Ember CLI находится в версии 3.9, которая составляет 13 месяцев. Так я вошел в npm install -g ember-cli в терминал, но я получаю сообщение об ошибке: npm ERR! Error: EACCES: permission denied, access ...
Есть ответ!
Я пытаюсь создать npm vue component library. Я проработал все шаги, но застрял на npm publish. Пожалуйста, посмотрите приведенный ниже скриншот ошибки, для которой я не могу найти решение в google после попытки более часа(сообщение об ошибке не так точно IMHO или, может быть, я не в состоянии поймать его). Для справки package.json { "name": "@satyam/vue-components", "version": "0.1.0",...
Есть ответ!
В принципе, я хочу реализовать discord rpc в моем электронном браузере Application, и я нашел этот модуль npm для него. Я заметил, что не могу импортировать его с помощью узла по умолчанию.JS way, мое приложение просто игнорирует его таким образом const client = require('discord-rich-presence')('180984871685062656'); Мне нужно будет импортировать его с помощью импорта (насколько я знаю) impor...
Есть ответ!
Я только что разместил свой сайт на Heroku. Ожидаемый результат: живая версия моего приложения VueJS, "Твиттер-клон". Данные, там синхронизация моем GitHub на Heroku. Теперь у меня проблема. https://rolys-twitter-clone.herokuapp.com/ это мой сайт, не так много, чтобы увидеть, потому что есть сообщение об ошибке Он гласит: An error occurred in the application and your page could not be served...
Есть ответ!
У меня есть проект Laravel, и я хочу сгенерировать css-файл из scss. Мой файл webpack.mix.js выглядит следующим образом: mix.sass('resources/assets/sass/style.scss', 'public/css/style.css'); когда я запускаю команду npm run dev у меня есть ошибка: ERROR in ./resources/assets/sass/style.scss Module build failed: ModuleNotFoundError: Module not found: Error: Can't resolve '../images/bg-main.png'...
Есть ответ!
Я загрузил nuxt проекта на Linux-сервер через Git, следует 'НПМ обновление nuxt", а затем "НПМ запустить строить'. Однако, я столкнулся с ошибкой при построении. Что же мне делать? Вот мой код ошибки FATAL Nuxt build error 00:42:06 at WebpackBundler.webpackCompile...


Закрыть X